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IMPORTANT NOTES

2

• This tutorial focuses mainly on the integration 
of TSV with 3D-OASIS-NoC router. 

• It covers the TSV creation, synthesis, place and 
route, and LVS  and DRC check. 

• Post layout simulation and pad insertion steps 
are not included. 

• Complete details about the execution of these 
two steps can be found in the previously made 
technical report [Ref.1].
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Objectives
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• After completing this tutorial you will be able to:

1. Design TSV layout using Virtuoso

2. Synthesize 3D-OASIS-NoC (3D-ONoC) router with TSV 
using Design-Compiler CAD tool

3. Place & Route (P&R) 3D-ONoC router with TSV   
using Cadence SoC-Encounter

4. Learn how to make TSV layout, the synthesis and 
P&R via: 

• The CAD Graphic User Interface

• Tcl script



Prerequisite

• Understand the previously made “OASIS 3D-
Router Hardware Physical Design” technical
report [Ref.1].

• Study 3D-OASIS-NoC architecture and its main
components [Ref.2].

• Read the Manual and Release Notes of the
FreePDK3D45 design tool kit [Ref.3] and
understand the aspects of the used TSV
component.
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1. Environment

<== Back to Contents
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Tutorial
directory structure

LEF_File

Syn

PandR

FreePDK3D45

DB

output_files

SRC

Path:~ /3D-TSV
reports

script
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output_files

script

vnet



Environment: FreePDK3D45
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• The Process Design Kit used in this tutorials are
obtained from NCSU FreePDK3D45.

• Go to: http://www.eda.ncsu.edu/eda_registration.php

• Verification is required so enter your email
address.

• You will receive an email with a link to download
FreePDK3D45.

• Extract the downloaded archive and copy the
FreePDK3D45 folder in your working directory:

/home/zxp035/3D-TSV/LEF_File

http://www.eda.ncsu.edu/eda_registration.php


Environment: Setup

9Go to /home/zxp035/3D-TSV/LEF_File where the TSV folder is located



Environment: Setup

10Type emacs FreePDK3D45/nscu_basekit/cdssetup/setup.csh &



Environment: Setup
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Change the following paths to link to the FreePDK3D45 libraries:

- /local/home/wdavis/fp3d/FreePDK3D45→         /home/zxp035/3D_TSV/LEF_File/FreePDK3D45
- /afs/eos/dist/cadence2008/ic →         /opt/vdec/Cadence/IC_06.15.011



Environment: Setup

12Initially bash will start, so type “tcsh” to start cshr



Environment: Setup

13Type source FreePDK3D45/ncsu_basekit/cdssetup/setup.csh



2. TSV Layout

<== Back to Contents
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Virtuoso:  TSV layout steps

15Type virtuoso& to start Virtuoso



Virtuoso: TSV layout steps

16Welcome Command Interpreter Window(CIW)



Virtuoso: TSV layout steps
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First, we should create a library. 

Click Tools->Library Manager



Step1: Create library

18Click File -> New -> Library



Step1: Create library
a- Library name
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1. In Library Name, type TSV_layout
2. Click OK

1

2
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Step1: Create library
b- Technology file

1. Check Reference existing technology libraries
2. Click OK

1

2
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Step1: Create library
b- Technology file

1
2

3

1. Click NCSU_TechLib_FreeFDK3D45
2. Click -->
3. Click OK



Step2: Create cell view

221. Click TSV_layout
2. Click File -> New -> Cell View to create cell view

1

2



Step2: Create cell view
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1. In File:
- Library: select TSV_layout
- Cell:      type TSV_layout
- View: type layout
- Type: check layout

2. Click OK

1

2



Step2: Create cell view

24In both appeared pop-up messages, click Yes



25Click your library -> Cell -> layout

Step2: Create cell view
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Step3: Create TSV layout

Welcome Virtuoso Layout screen 
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Step3: Create TSV layout
a- Create TSV instance

Click Create -> Instance
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Step3: Create TSV layout
a- Create TSV instance

1

2

3

4 1. Click Browse
2. Click LVS_test -> VIA_Stack_A
3. Click Close
4. Click Hide
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Step3: Create TSV layout
a- Create TSV instance

Click point(X: 2.0625 Y: 2.0375). 

You may use the ruler in the toolbar for precision
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Step3: Create TSV layout
a- Create TSV instance

Right click on the created VIA_Stack_A, and click Properties

1. In Origin: X type 2.03
2. In Origin: Y type 2.03

1 2
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Step3: Create TSV layout
b- Create input pin

1. Click metal1 pin
2. Click Create -> Pin

1

2
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Step3: Create TSV layout
b- Create input pin

1

2

3

4

1. Terminal Names → IN
2. Mode → rectangle
3. I/O Type → input
4. Click Hide
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Step3: Create TSV layout
b- Create input pin

Click point(X:3.06 Y: 3.06) 
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Step3: Create TSV layout
b- Create input pin

Drag the pointer to point(X:4.06 Y: 1.00) and click 
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Step3: Create TSV layout
b- Create input pin

Right click on the created Input pin and click Properties

1. Select metal1 pn
2. Type 

Left: 3.06

Right: 4.06

Bottom: 1
Top: 3.06

3. Click OK

1

2

3
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Step3: Create TSV layout
b- Create input pin

Click Create -> Pin

2
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Step3: Create TSV layout
b- Create input pin

1

2

3

4

1. Type IN
2. Check rectangle
3. Check input
4. Click Hide
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Step3: Create TSV layout
b- Create input pin

Click point(X:4.06 Y: 1.00) 
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Step3: Create TSV layout
b- Create input pin

Drag the pointer to point(X:0.00 Y: 0.00) and click 



40

Step3: Create TSV layout
b- Create input pin

Right click created Input pin and click Properties

1. Select metal1 pn
2. Type

Left: 0

Right: 4.06

Bottom: 0
Top: 1

3. Click OK

1

2

3
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Step3: Create TSV layout
b- Create input pin
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Step3: Create TSV layout
c- Create path

1. Click metal1 drawing
2. Click Create -> Shape -> path

2

1
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Step3: Create TSV layout
c- Create path

Click point(X: 2.0625 Y: 2.0375) 
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Step3: Create TSV layout
c- Create path

Drag the pointer to point(X:4.06 Y: 2.0375) and double click 
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Step3: Create TSV layout
c- Create path

Right click on the created path and click Properties

1. Select metal1 dg
2. Type

Points: (2.0625 2.0375) (4.06 2.0375)
Width: 0.065

3. Click OK

1

2

3
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Step3: Create TSV layout
d- Create output pin

1. Click TM pin
2. Click Create -> pin

2

1
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Step3: Create TSV layout
d- Create output pin

1

2

3

4

1. Type OUT
2. Check rectangle
3. Check output
4. Click Hide
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Step3: Create TSV layout
d- Create output pin

Click point(X: 1.03 Y: 3.03) 



49

Step3: Create TSV layout
d- Create output pin

Drag the pointer to point(X:3.03 Y: 1.03) and click 
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Step3: Create TSV layout
d- Create output pin

Right click created Output pin and click Properties

1. Select TM pn
2. Type

Left:      1.03

Right: 3.03

Bottom: 1.03
Top: 3.03

3. Click OK

1

2

3
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Step3: Create TSV layout

The TSV layout is completed.
Click the Save Icon



Step4: Export LEF

52Click File -> Export -> Lef to create lef file



Step4: Export LEF
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1. In LEF File Name, Type TSV.lef
2. Click on Output Cell
3. Click INVS_test
4. Click OK

1

2

3

4



Step4: Export LEF
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1. Click on Output View
2. Click layout
3. Click OK

1



Step4: Export LEF

55Click OK



Step4: Export LEF

56TSV.lef is exported without any errors.



3. Modify lef file

<== Back to Contents
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Modify lef file

58Type emacs TSV.lef &



Modify lef file
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Before After

Add codes in red rectangle



Modify lef file
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Before After

Delete codes in a red part

…



Modify lef file
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Before After

Delete codes in red rectangle



Modify lef file
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Before After

Delete codes in red rectangle

…



Modify lef file

63Add codes in red rectangle

Before After



Modify lef file

64Add codes in red rectangle

Before After



Modify lef file

65Add codes in red rectangle

Before After



Modify lef file

66Add codes in red rectangle

Before After



Modify lef file

67Add codes in red rectangle

Before After



4. Synthesis

<== Back to Contents
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Step0: Notes
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• In this tutorial, the synthesis step is performed 
using a .tcl script with a minimal use  of Synopsys 
Design Compiler Graphic User Interface (GUI).

• To understand in details the different synthesis 
operations using GUI, please refer to the 
previously made technical report [Ref.1].



Step1: Environment

70Go to /home/zxp035/3D-TSV/Syn



Step2: syn_LAFT.tcl

71Type emacs scripts/syn_LAFT.tcl & to see the script



Step2: syn_LAFT.tcl
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Step2: syn_LAFT.tcl
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Step2: Run syn_LAFT.tcl

74Type dc_shell-xg –f scripts/syn_LAFT.tcl to run the script by design compiler



Step2: Run script

75If red rectangles are all “1”, the script execution is succeeded



Step3: Run GUI

76Type start_gui



Step3: Run GUI

77Click 



Step3: Run GUI

78Red rectangles are TSVs



4. Place & Route

<== Back to Contents
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Step0: Notes
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• In this tutorial, the Place and Route step is 
performed using both commands and GUI. 

• How to execute the commands using GUI, is 
explained in details in the previously made 
technical report [Ref.1].



Step1: Environment

81Go to /home/zxp035/3D-TSV/PandR



82Type cp ../LEF_File/TSV.lef macro/

Step1: Environment
a- Copy the files



83Type cp ../Syn/output_files/router_LAFT.vnet vnet/

Step1: Environment
a- Copy the files



84Type emacs vnet/router_LAFT_TSV.vnet &

Step1: Environment
b- Modify the .vnet file
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Step1: Environment
b- Modify the vnet file

…

Delete codes in a red part
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Step1: Environment
b- Modify the vnet file

Change from TSV_163 to TSV

Before

After
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Step1: Environment
b- Modify the vnet file

…
Change from TSV_* to TSV

…

Before After
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Step2: Run SoC Encounter

Type velocity to start SoC Encounter
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Step2: Run SoC Encounter

Welcome screen of SoC Encounter. 
The CUI is on the left side and the GUI is in the right side.
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Step3: Import Design

Execute the commands on the right hand in the CUI line by line 
to import the previously synthesized design
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Step3: Import Design

The initial chip layout after importing the design
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Step4: SoC Floorplan and macro

Execute the commands on the right hand in the CUI line by line 
to set floorplan and macro locations

…
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Step4: SoC Floorplan and macro

Chip layout after Floorplan and macro placement
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Step5: Power ring

Execute the commands on the right hand in the CUI line by line 
to add the power ring

…



95

Step5: Power ring

Chip layout after adding the power ring



96

Step6: Power Stripe

Execute the commands on the right hand in the CUI line by line 
to add power stripe



97

Step6: Power Stripe

Chip layout after adding the power stripe
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Step7: Power Routing

Execute the commands on the right hand in the CUI line by line 
to make special route
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Step7: Power Routing

Chip layout after making the special route
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Step8: Placement

Execute the commands on the right hand in the CUI line by line 
to place the standard cells 
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Step8: Placement

Chip layout after placing the standard cells
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Step9: Optimization

Execute the commands on the right hand in the CUI line by line 
to perform the Pre-clock synthesis optimization
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Step9: Optimization

Chip layout after the Pre-clock synthesis optimization
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Step10: Clock Tree

Execute the commands on the right hand in the CUI line by line 
to synthesize clock tree
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Step10: Clock Tree

Chip layout after synthesizing the clock tree



106

Step11: Optimization

Execute the commands on the right hand in the CUI line by line 
to perform the Post-clock synthesis optimization
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Step11: Optimization

Chip layout after Post-clock synthesis optimization
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Step12: Nano Route

Execute the commands on the right hand in the CUI line by line 
to add Nano route
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Step12: Nano Route

Chip layout after Nano-route
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Step13: Optimization

Execute the commands on the right hand in the CUI line by line 
to perform the Post-route optimization
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Step13: Optimization

Chip layout after Post-route optimization
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Step14: Adding Fillers

Execute the commands on the right hand in the CUI line by line 
to add fillers
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Step14: Adding Fillers

Chip layout after adding fillers
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Step15: Layout Vs. Schematic(LVS)

Execute the commands on the right hand in the CUI line by line 
to perform the LVS check
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Step15: Layout Vs. Schematic(LVS)

LVS check report on the CUI
Successful check (No errors and no warning)
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Step16: Design Rule Check(DRC)

Execute the commands on the right hand in the CUI line by line 
to perform the DRC check 
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Step16: Design Rule Check(DRC)

DRC check report on the CUI
Successful check (No violations and no warning)
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Step17: Output files

Execute the commands on the right hand in the CUI line by line 
to generate the output files and finish P&R



PandR.tcl script (1/5)
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PandR.tcl script (2/5)
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PandR.tcl script (3/5)
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PandR.tcl script (4/5)
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PandR.tcl script (5/5)
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Final chip layout
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